'CVE-2013-2251'에 해당되는 글 1건

  1. 2013.07.19 [주의]아파치 Struts2 취약점(CVE-2013-2251) 이용 공격도구 증가 중
1. Apache Struts2 원격코드 실행취약점 업데이트 권고


잉카인터넷 대응팀은 중국내 언더그라운드 사이트에서 아파치 Struts2 취약점을 이용한 Exploit 코드와 공격도구가 다수 배포되고 있는 점을 확인하였다. 아파치 Struts2 프로그램은 자바 웹 프로그램 구축을 위한 프레임 워크이다. 따라서 해당 취약점을 이용한 공격이 증가할 것으로 우려된다. 아파치 Struts2 버전을 이용하고 있는 웹서버 관리자는 신속히 2.3.15.1 이상의 상위버전으로 신속히 업데이트를 하여야 한다. 보안이 취약한 버전을 사용할 경우 해킹에 의해서 홈페이지 변조 및 데이터 베이스 정보 유출 등의 피해를 입을 수 있으므로, 서버 관리자들의 신속하고 적극적인 조치가 요구된다.

[CVE-2013-2251 취약점 정보]
- http://struts.apache.org/release/2.3.x/docs/s2-016.html
- http://struts.apache.org/release/2.3.x/docs/s2-017.html

2. Apache Struts2 취약점 공격 도구

현재 중국의 다수 사이트에서 관련 공격 도구가 지속적으로 등장하고 있으며, 2013년 07월 17일 오후부터 중국의 대형 사이트들이 공격을 받고 있다. 이미 다수의 공격도구들이 무차별적으로 공격에 이용되고 있기 때문에 신속한 업데이트가 필요하다.

한국의 사이트들도 공격대상에 포함되고 있는 것으로 알려진 상태이므로, 아파치 Struts2 를 운영중인 웹 서버 관리자들은 신속한 보안 업데이트가 필요하다.

아래는 대표적인 공격도구들의 화면이며, 잉카인터넷 대응팀은 해당 악성도구에 대한 탐지 및 치료기능을 nProtect 제품군에 추가하였다. 지속적으로 새로운 종류를 수집하여 대응할 예정이며, 일부를 공개하면 아래와 같다.


3. 취약점 제거 방법

해당 웹 서버 운영관리자는 신속히 알려진 취약점이 제거된 아파치 Strusts 2.3.15.1 상위 버전으로 업데이트 한다.

http://struts.apache.org/download.cgi#struts23151

Struts 2.3.15.1

Apache Struts 2.3.15.1 is an elegant, extensible framework for creating enterprise-ready Java web applications. It is available in a full distribution, or as separate library, source, example and documentation distributions. Struts 2.3.15.1 is the "best available" version of Struts in the 2.3 series.

저작자 표시
신고
Posted by nProtect